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CAD Programming Overview 
 
Creating a measurement plan from a CAD model is by far the easiest way to program 

Calypso.  Not only is it faster than using “teach-in” but all of your feature and 
characteristic nominals come directly from the model.  This document outlines the CAD 
programming tools available in Calypso, the steps typically used to create a program with 

a CAD model, and some additional useful CAD functions. 

 

 

CAD Programming Tools 

When you are programming off the model, you have to use the mouse to create features 

in your program.  The CAD programming tools are located at the far left of the CAD 
toolbar.  Only the most used tools are described here and the list on the right shows them 

in order of most used.  They will work with a single left click on a surface. 
 

 

 
 

 
 

 

 
 

 
 

 
 

 
 

 
1. Define/Select Geometry 

When clicking on a surface that has not been defined (added to the feature list), a new feature 

is created.  If the surface is already in the feature list, Calypso selects the existing feature. 

2. Select Already Extracted Features 
If the surface clicked on the model is in the feature list Calypso selects it; otherwise nothing 

happens.  This is the default tool when you open a measurement plan. 

3. Define a Circle on a Cylinder 
Instead of creating a cylinder or cone, a circle is created on the surface exactly where it was 

clicked. 

4. Define a Space Point 
A point feature is created at the location clicked.  The vector will be normal to the 

surface. 

5. Define Points 
Works exactly like manually probing the part with the CMM (auto feature recognition). 
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CAD Programming Steps 

 

1. Load the CAD model 

Create a new program and select CAD>CAD File>Load… 

 
** The files type pulldown in the File Open dialog will show you what CAD formats you can load 

into Calypso.  This can also be found in Extras>Settings>Miscellaneous… 

 

 

2. Heal the model (optional) 

Some CAD models (especially IGES) have issues and need some “massaging” before 

the can be effectively used in Calypso.  The healing functions in Calypso attempt to fix 

these imperfections.  To open the heading dialog select CAD>CAD File>Automatic Healing. 

 

    
 

 

 

 

 

Typically you will only need to do Simplification, Stitching, and Correct Boundary 

curves. 

 Simplification:  Converts spline geometry into their corresponding analytic forms 

(e.g. arc, cone, plane, etc.), wherever possible.  This will change your model so 

don’t change the tolerance (default is 10μm). 

 Stitching:  Combines sets of faces to form a single sheet or solid body (e.g. 2 

halves of the same cylinder). 

 Build Geometry: A series of geometric operations are performed to improve the 

precision of face, edge, and vertex data.  Essentially the model is completely 

rebuilt.  The only time it is good to use this is if the model is still unusable after 

simplification & stitching.  Typically only IGES models need build geometry, but not 

always. 

 

** Native CAD files (UG, ProE, Solidworks, Catia, etc.) rarely need to be healed. 
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3. Change the orientation of the model (optional) 

More often than not it seems that the easiest way to stage the part on the CMM does 

not match the orientation of the model.  Prior to starting the program you will want to 

orient your CAD model so that the X, Y, & Z axes match the way the part is setup on 

the CMM.  To change the orientation of the model select CAD>Modification>CAD 

Model Transformation…  It is not necessary to shift the model origin since it will be 

replaced by the Base Alignment once it is defined. 

           
 

Example:  To rotate the model 90° about the Y-axis, select 

Y in the Space Axis pulldown, enter 90 in the Angle box, and 

then click Apply.  If you rotated the wrong way change, 

change the sign of the angle and click Apply.  This will put 

you back to your original location. 

 

** When you click Apply the model is both translated & rotated by the values listed.  

Be cautious of what’s in each box before you click Apply. 

 

 

4. Setup Default Strategies (optional) 

Go into Resources>Save/Load Defaults to setup appropriate measuring strategies for 

the features you intend to measure.  Also activate Filters & Outliers with appropriate 

settings for your part. 

 

 

5. Create Base Alignment 

 From the Measurement Tab, click the button for Base/Start Alignment then click OK 

to create a new base alignment 

 Change you CAD tool to Define/Select Geometry 

 Left click on the features in the CAD model that you want to use for the primary, 

secondary, & tertiary datums in that order.  As you click a feature, that feature will 

be used in as many slots in the template as possible. 

 

** An alternate method is to use the Define/Select Geometry tool to add the datums 

features to the feature list then manually fill in the Base Alignment template.  This is 

typically recommended is you have constructions as part of the base alignment. 
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6. Create Clearance Planes 

 From the Measurement Tab, click the Clearance 

Planes button. 

 Click the button in the upper left of the clearance 

planes window for “Clearance Plane from CAD Model”. 

 In the Edge Distance dialog enter a value for how 

much bigger than the part the clearance planes 

should be.  The default value is 10mm (0.3937”) 

which is usually sufficient.  Click OK and the clearance 

planes are automatically generated.  

 

 

 

 

7. Creating Characteristics 

 Add a characteristic from either the Size or Form and Location pulldown menu. 

 Open the characteristic and, using Define/Select Geometry (or the appropriate) 

tool, select the feature for the characteristic on the CAD Model. 

 If necessary, click the datum features. 

 Enter the tolerance and make any necessary changes (name, tolerance type, etc.) 

 

**As it did with the Base Alignment template, selecting features in a characteristic 

template will cause Calypso to insert that feature into the first appropriate position. 

 

 

8. Edit Measurement Strategies 

For each feature you create you will want to verify that the measuring strategy 

automatically created will work.  Below are some notes about creating/editing strategy 

in CAD (most of these work whether or not you loaded a model…remember you always 

have a CAD model in Calypso. 

 Planes 

o Points:  When the strategy window is you can click & drag points around the 

surface.  Hover the mouse over the point on the surface (not the arrow, the 

icon will change to hand) then click and drag the point to its new location.   

o Polylines:   

 With a polyline strategy open, clicking in the model will add those 

points to the polyline (exactly the same as manual probing with the 

CMM).  Already created points can be moved by clicking and dragging. 

 The “Polyline from Model” button will automatically create a polyline to 

match the actual shape of the plane.  When you click the button you 

will be prompted for an offset which is how far in from the outer edges 

the polyline will be created. 
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 Multi-polyline:  When you click this strategy button you are 

immediately prompted for and edge distance.  Calypso will then create 

a polyline around each edge on the surface. 

o Circle Path:  You can click and drag the center point (X) of a circle path to 

reposition it and on the circle itself to change the size. 

 Cylinders/Cones:  You can click and drag circle paths to move them up/down on the 

feature. 

 

 

 

9. Run the Program 

Since this program was created using a CAD model the CMM assumes that the Base 

Alignment of the part is located at machine home (back, upper left corner of the CMM).  

The first time the program is run you must select “Manual Alignment” on the run 

menu.  Once the alignment has been run manually you can run the program as 

normal. 
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Other Useful CAD Functions 

 

 Delete the CAD Model 

To delete the CAD model from a program select CAD>View>Delete.  The model 

will be immediately removed from the program.  Note that there is no undo and 

closing the program without saving changes will not have an effect. 

 

 

 CAD Model Comparison 

Occasionally the link between the features in a program and the CAD model gets 

broken or never existed to begin with in the case of creating features from the 

pulldown menus or copying and pasting features between programs.  It may also 

be necessary to delete an existing model and load a new updated model.  In this 

case the features in the program will not be linked to the CAD model.  The CAD 

Model Comparison tool can be used to re-establish the link between features and 

the model 

o Select CAD>CAD File>CAD Model Comparison… 

o Set the tolerance and click the Comparison 

button.  The list will be populated with the 

features in your program.  In parenthesis 

Calypso will list a CAD entity with which the 

feature can be linked.  It also lists the 

deviation between the feature and the 

associated entity.  Selecting and feature in the 

list will highlight the potential associated 

feature in the model. 

o Highlight the features you want to be linked 

(regardless of in or out of tolerance) then click 

Apply and close the window. 

 

 

 Settings 

Under CAD>Settings… you can change the look and feel of the CAD model.  There 

are many settings but here is a short list of some of the most common items to 

change: 

o Display:  Allow you to change the color of the model, background, & 

selected feature. 

 Image Quality:  This setting determines how precise the CAD model 

is drawn on the screen.  It does not have anything to do with the 

accuracy of the model just how much of your computer’s resources are 

being used to draw the model.  For small parts it can be advantageous 

to change this to Fine.  Make sure to hit apply after changing the 

setting. 
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 Edges/Curves:  Setting for the color of the wireframe part of the 

model.  It’s usually best to pick a color that contrasts with the surface 

color. 

o Stylus Path:  Color of the strategy paths, arrow size for single points, point 

style (x or probe tip), and other options. 

o Text:  Can turn off feature names in the model and/or change the color 

 

 

 Evaluation 

This function allows you to display point deviations in the CAD model.  It is found 

under CAD>Evaluation.  Prior to adjusting the settings it’s best to have a 

calculated characteristic (red or green background) selected so you can see the 

effects of your changes real time.  Everything below refers to the Actuals tab. 

o Check the box next to Actual to turn the evaluation on/off 

o There are 4 ways to displays the deviations:  Points, Polyline, Markers, & 

Triangles.   

o Markers (Whiskers) is a format most people like.  A size between 0.25 and 

1.0 works well depending on the point density. 

o Activating the Color Gradient will color code each marker based on where the 

corresponding point fell within the tolerance range.  The properties button 

can be used to modify the colors.  Changing the color map to “Color Classes” 

with 10 steps is a good setting. 

o Magnification exaggerates the deviations making them easier to see on the 

model. 

 

 

 Creating Features 

Features can be created directly from elements in the CAD model under 

CAD>Creating Features…  It is usually easier to simply extract features using 

the Define/Select Geometry tool but sometimes that tool is not precise enough.  

Below are two common things to do under the Creating Features menu. 

o Points 

 Found at the bottom of the Creation tab, this tool allows you to 

create a point feature at an exact location on the model. 

 To create a point, type in the X, Y, & Z coordinates (relative to 

the base alignment) and click the point button to the left of the 

pulldown. 

 If the coordinates typed in don’t lie on the CAD model, Calypso 

will create the point on the closest surface. 

o Section Tab 

 This tab allows you to slice or section the model to create entries 

to use on the Creation tab. 
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 The sectioning can be done with a plane or a cylinder.  Once you 

change any of the values the plane/cylinder will appear in the 

CAD model. 

 Once the section plane/cylinder is located and sized where you 

want it click the Section button.  Entities are created on the CAD 

model everywhere the section plane/cylinder intersects a 

surface. 

 

 

 Importing multiple models 

Multiple models can be imported into a Calypso program.  A common scenario for 

this is separate models for the part and the fixture.  This can be done by simply 

using CAD>CAD File>Load… multiple times.  If the models don’t share the same 

origin it will be necessary to reposition one or both of the models.  This can be done 

under CAD>Modify CAD Entities… There are two ways to move the bodies 

(models):   

o Transformation Tab (positioning with exact values) 

 Click on one of the bodies (models) 

 Use the X, Y, & Z boxes for translation and the boxes below each for 

rotation about that axis.   

 After typing in a transformation value a ghosted image of the body will 

appear in the model window showing you where it will be after the 

transformation.  Click Apply for it to take effect. 

o Positioning Tab (positioning by clicking in the CAD model 

 Click the Position button in the middle of the page 

 Click a point on the body you want to move 

 Click a second point on the surface where you want the first point 

located. 

 A ghosted image of the body will appear in the model window showing 

you where it will be after the transformation.  Click Apply for it to take 

effect. 

 

** It’s important to perform this manipulation prior to healing the model.  Prior to healing 

each model is considered a separate bodies and thus allows you to move each one 

independently.  After healing everything is combined into a single body and cannot be 

manipulated separately. 

 


